Uploaded image for project: 'KFS Archive'
  1. KFS Archive
  2. KFSOLD-23383

CAMS - NPE when initiating Asset Manual Payment Document

    Details

    • Type: Bug Fix
    • Status: Closed
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: Canceled/Declined
    • Labels:
      None
    • Sub-Committee:
      CAM / CAB
    • Impacted Modules:
      Capital Asset Management
    • Contributing Partner:
      University of Maryland
    • Rice Change Required?:
      No
    • Rice Data:
      No Change
    • Data Structures:
      No Change
    • KFS Data:
      No Change
    • Configuration Properties:
      No Change
    • Libraries:
      No Change

      Description

      When initiating the manual asset payment document, the form is trying to retrieve the document from the session but if the session is disabled or document number is null then it will throw an null pointer exception. It may not be a problem at foundation but at UMD we are using rice 2.2.3 and we are seeing this NPE behavior.

        Attachments

          Issue Links

            Activity

            bhutchinson Bryan Hutchinson added a comment - - edited

            Muddu,

            I linked some Rice JIRAs that I think are related.

            KULRICE-9148 - Rice JIRA for disabling the session document service in Rice 2.1.3/2.2.2
            KULRICE-9358 - Rice JIRA to put at least some of that functionality back in Rice 2.1.6/2.2.4 because of unintended side-effects.
            KULRICE-9380 - Rice JIRA for related future refactoring currently in 2.3-backlog

            Here's also a link to KTI meeting minutes where this was discussed: https://wiki.kuali.org/x/IB1UEw

            I'm wondering if you ran up against one of the unintended side-effects of the original change at UMD and if upgrading to Rice 2.2.4 (or pulling in the related fix to your 2.2.3) would address it?

            I don't think there is currently anything for us to do in KFS since the issues we originally found have been corrected, the important functionality was put back, and we don't have any plans to move KFS to the 2.2.x Rice line. We're on 2.1.6 and plan to stay on the 2.1.x line until we move to KRAD with 2.4.

            Thanks,
            Bryan

            mksalem Muddu Salem added a comment -

            Thanks, Bryan. I will look into the related rice jiras. I should mention that the NPE issue is not a problem with foundation code on int and we tested and confirmed that it works correctly there. If session document server ever removed then we need to refactor the code in KFS to fix the NPE issue

            bhutchinson Bryan Hutchinson added a comment -

            Muddu,

            Given that, I think this contribution should be cancelled, and the linked KFSMI JIRA should be closed as "won't fix". If/when Rice makes more changes related to the session document service in a version we're using for KFS, we'll keep an eye out for the NPE you saw.

            Thanks,
            Bryan

            mksalem Muddu Salem added a comment -

            This issue will be revisited when rice 2.2 removes session document service support.

            tcain Theresa Cain added a comment -

            IU contribution KFSCNTRB-1809 will fix this for the foundation.


              People

              • Assignee:
                Unassigned
                Reporter:
                Anonymous
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: