KFS Archive
  1. KFS Archive
  2. KFSOLD-23392

"action type" column on Organization Review lookup not populating correctly for delegations

    Details

    • Type: Bug Fix Bug Fix
    • Status: Closed Closed
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: Canceled/Declined
    • Labels:
      None
    • Sub-Committee:
      COA / FP / GL
    • Impacted Modules:
      System
    • Contributing Partner:
      Indiana University
    • Rice Data:
      No Change
    • Data Structures:
      No Change
    • KFS Data:
      No Change
    • Configuration Properties:
      No Change
    • Libraries:
      No Change

      Description

      the action type code on the Organization Review lookup is not populating for Delegations.

      Notes from Jonathan on previous JIRA:

      There does not seem to be a way to do this on the lookup. The information passed back from KIM does not contain that information. The returned information does not contain the action information (priority, action type, action policy). And, there is no good way to pick out that information in the context of the lookup. (I worry about killing performance as the only way would be to individually attempt to pull the information for each delegation in the results.)

      It's complicated, since that information is inherited from the role member and is not associated with the delegate. The delegate is only associated with the role member. In a one-off situation (as in the document), the information can be pulled. But in a list-view situation, it may not be practical. I think this may need to get thrown to the Rice team as an addition to the KIM APIs so that it can be resolved there before getting passed back to KFS.

      I'll link the associated RICE JIRA for the API work.

        Issue Links

          Activity

          Heather Elyea added a comment -

          changing hours to zero since we didn't change anything, but we are waiting to mark this issue as cancelled until the linked jira is resolved so that we can confirm that things are working properly.

          Barb Sutton added a comment -

          Hi Heather,

          This one has me confused for several reasons. Is this the cause of KFSMI-7477? If so, it does not appear to be fixed.

          I'm also unclear as to the status of this since this issue is a contribution but doesn't appear to have passed project review. It's linked to KFSMI-6084, which has a fix for Release 6 (whereas this contrib JIRA says release 5).

          Thanks,
          Barb

          Heather Elyea added a comment -

          Here's my understanding. James or Kalani can jump in if we're both a little confused.

          1. KFSMI-6084: This issue was created as the contribution to fix KFSMI-6084. When this contribution jira was created, 6084 should have been marked as "Release ?".
          2. KFSMI-7477: This is a separate issue that is partially blocking the testing of this issue. But Kalani faked the url to bypass that bug for her testing.
          3. However.. during the testing and debugging of this issue, Kalani discovered that the problem from 6084 is no longer happening. We're waiting until KFSMI-7477 has been resolved to confirm testing without our hack to the url. But once confirmed, we'll cancel this contribution and resolve KFSMI-6084 as "cannot reproduce".

          Does that help?

          Heather Elyea added a comment -

          Cancelling this contribution because through our testing we discovered that this was no longer breaking even though we didn't change anything.

          Damon will test KFSMI-6084 once KFSMI-7477 is fixed.

          Barb Sutton added a comment -

          Changing to functional proposal accepted - no since contribution was cancelled.


            People

            • Assignee:
              Unassigned
              Reporter:
              Heather Elyea
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Structure Helper Panel