KFS Archive
  1. KFS Archive
  2. KFSOLD-23936

Add a Generate button to the Capital Asset Information tab to add accounting lines to the appropriate Create/Modify Capital Asset tabs; once added, the accounting lines will become read only

    Details

    • Type: Code Cleanup Code Cleanup
    • Status: Resolved Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.1.x
    • Labels:
      None
    • Sub-Committee:
      CAM / CAB, COA / FP / GL
    • Impacted Modules:
      Capital Asset Management
    • Functional Work:
      4 - None
    • Contributing Partner:
      Indiana University
    • Rice Change Required?:
      No
    • Rice Data:
      No Change
    • API Changes?:
      Unspecified
    • Data Structures:
      No Change
    • KFS Data:
      No Change
    • Configuration Properties:
      No Change
    • Libraries:
      No Change

      Description

      Part 1.
      While the Accounting Lines for Capitalization tab requires a unique accounting line, if the processor has already created Create Capital Assets, or Modify Capital Asset data, the document will allow the processor to update the accounting line, hit refresh which updates the accounting record in the Accounting Lines for Capitalization tab, but the refresh does not update the accounting records in the Create Capital Assets tab, or the Modify Capital Asset Tabs. This allows records into cab that are not unique and then they become stuck in CAB.

      In addition the refresh button on Modify asset does update the Capital Asset for Accounting Lines. As part of this jria let’s remove the refresh button.
      I’m not sure what the simple fix is here.

      1.A refresh of an accounting line updates the Accounting lines for Capitalization, and the corresponding accounting lines in Create Capital Asset and or accounting lines in Modify capital assets.

      2.A refresh of an accounting line updates the Accounting lines for Capitalization, and if the accounting exists in Create Capital Assets and or Modify Capital Assets the records in these tabs are deleted, thus unchecking the selected line in the Accounting lines for Capitalization tab.

      3.Add a check between Accounting Lines for Capitalization and the Capital Asset for Accounting Lines in the Create Capital Assets and Modify Capital Assets tabs. If the Line Type, Chart, Account, Sub-Account, Object, Sub-object, Project, Org Ref Id are not in agreement present an error message.
      Error Message: An accounting record has been updated in the Accounting Lines for Capitalization tab after the asset accounting lines were created. Please delete the asset record and re-select the accounting line in the Accounting Lines for Capitalization tab for processing.

      This bug can be reproduced on any financial document that collects asset information. For our test case we will use the DI.
      Steps.
      1. IU user id khuntley
      2. Distribution of Income and Expense
      3. From Accounting Line
      a. BL, 1024700, object 5200, amount 88.00
      b. BL, 1024700, object 5200, amount 11.96
      4. To Accounting line
      a. BL, 1024700, object 7000, amount, 88.00
      b. BL, 1024700, object 7000, amount 11.96
      5. In the Accounting Lines for Capitalization tab select both accounting lines for processing.
      6. Click on Modify asset
      7. Enter asset number 300763
      8. Click on button redistribute total amount.
      9. Submit document. Which will present error message: On capital asset accounting lines, each line must be unique in order to be properly attributed to a single asset by the Capital Asset Builder module. If you have multiple, identical lines, please combine them into one.
      10. On the Accounting lines tab, in the “to” section on accounting line 1 enter org ref id 1 and hit the refresh button.
      11. On the Accounting lines tab, in the “to” section on accounting line 2 enter org ref id 1 and hit the refresh button.

      Notice the change in the in the Accounting Lines for Capitalization tab, but not in the Modify Capital Asset, Capital Asset for Account Lines.

      When this document gets into cab, and has been processed, the system can’t identify what line has been processed. The actv_ind is not updated, and the trn_ldger_submit_amt is not set. CAB presents the action as process, when you get the processing tab, the action is processed.

      Now that this is fixed the scenario needs tweaked just a little so the document will successfully complete.
      =======================================================
      To successfully issue DI:
      1. IU user id khuntley
      2. Distribution of Income and Expense
      3. From Accounting Line
      a. BL, 1024700, object 5200, amount 88.00
      b. BL, 1024700, object 5200, amount 11.96
      4. To Accounting line
      a. BL, 1024700, object 7000, OrgRefID A, amount, 88.00
      b. BL, 1024700, object 7000, amount 11.96
      5. Click Generate Button
      6. In the Accounting Lines for Capitalization tab select both accounting lines for processing.
      7. Click on Modify asset
      8. Enter asset number 300763
      9. Click on button redistribute total amount.
      10. Submit document.

      Part 2
      Asset Manual Payment is presenting an Exception Report. When you open the asset manual payment document an error message is presented " description The server encountered an internal error () that prevented it from fulfilling this request."

      Testing is a simple as opening the asset manual payment, if it opens successfully the testing is complete.

      1. KFSCNTRB-1809.txt
        8 kB
        Theresa Cain
      2. KFSCNTRB-1809.txt
        201 kB
        Ying Feng
      3. KFSCNTRB-1809-patch-3.txt
        13 kB
        Ying Feng
      4. KFSCNTRB-1809-patch-4.txt
        7 kB
        Ying Feng
      1. CashReceipt.png
        179 kB
      2. debug screenshot showing source accounting line group definiation for Cash Receipt document.jpg
        397 kB

        Issue Links

          Activity

          Theresa Cain added a comment -

          Hi Barb,

          The issue is with the "To" capital lines on the document.
          Using document 4171 you have two options.
          1) in the "To" section enter only one capital line with the amount of 99.96,
          2) if you want to keep both capital lines then enter a unique value using the Org Ref ID field in one of the capital lines. I normally recommend the user use the asset number, but you can use anything you want as long as it makes the accounting line unique. The this edit was not changed as part of our contributed this rule existed before, we did move it so it is presented before the asset information is entered so you don't have to delete the asset information and start over because this accounting line was not unique. Let me know if you run into problems. Theresa

          Barb Sutton added a comment -

          Thanks Theresa, adding the org ref id did the trick (and makes sense). I should be able to finish this one up now

          Barb Sutton added a comment -

          I was unable to reproduce the error opening the Asset Manual Payment doc in KTD, so I was unable to see the issue in a previous version of KFS. There is no error when opening the Asset Manual Payment doc in INT, so testing passed.

          Steps to test both issues:
          Part 1 - Cap Edit on FP docs, error with multiple accounting lines using same accounting string being capitalized:
          1. Login as khuntley
          2. Create Distribution of Income and Expense
          a. From Accounting Lines
          1. BL, 1024700, object 5200, amount 88.00
          2. BL, 1024700, object 5200, amount 11.96
          b. To Accounting line
          1. BL, 1024700, object 7000, OrgRefID A, amount, 88.00
          2. BL, 1024700, object 7000, amount 11.96
          c. Accounting Lines for Capitalization tab - click Generate button
          1. Select both accounting lines for processing.
          2. Click on Modify asset
          a. Enter asset number 300763
          b. Click on button redistribute total amount.
          d. Submit document.

          Part 2 - Asset Manual Payment error opening document
          1. login as bomiddle
          2. Create Asset Manual Payment
          a. Asset = 1931
          b. Accounting Lines: BL-1031400-7000/$1000/Posted date = today, add line
          c. Submit
          3. Doc search - open doc (should not get error)

          Sandy Teague added a comment -

          Trying to pull down code for MSU. Noticed if you enter in a capital asset code on the transaction line the Accounting Line for Capitalization will show the generate button. If you change the accounting line object code to a non cap, the Accounting Line for Capitalization still displays the generate button. Even after clicking on the refresh button or the save button. Can't delete the accounting line. So it never revalidates to remove the generate button.

          Theresa Cain added a comment -

          Hi Sandy,

          Barb created jira KFMI-13556 to report this issue.


            People

            • Assignee:
              Unassigned
              Reporter:
              Anonymous
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Structure Helper Panel