Details

    • Priority Score:
      16
    • Functional Justification :
      This item has no functional justification.
    • Technical Justification:
      Hide
      Spring 3.0 offers numerous additional features over Spring 2.0.x which the Kuali Rice project is currently on. Since Kuali Rice 1.1 introduces a compatibility point in the Rice project, it is advisable to bring ourselves up to the latest version of this framework which is central and critical to Rice (and Kuali in general) architecture.
      Show
      Spring 3.0 offers numerous additional features over Spring 2.0.x which the Kuali Rice project is currently on. Since Kuali Rice 1.1 introduces a compatibility point in the Rice project, it is advisable to bring ourselves up to the latest version of this framework which is central and critical to Rice (and Kuali in general) architecture.
    • Impact if not Implemented:
      We may end up stuck on version 2.0.x of Spring if we are required to maintain a certain level of compatibility with it.
    • Priority - KFS:
      Critical
    • Priority - KC:
      High
    • Priority - KS:
      High
    • Priority - Rice:
      Critical
    • Theme:
      Versioning Compatibility
    • Application Impact:
      Low
    • Effort Estimate:
      Very Low ~ 50 hrs

      Attachments

        Issue Links

          Activity

          Hide
          coppola Chris Coppola (Inactive) added a comment -

          Updated based on f2f conversation in Chicago.

          Show
          coppola Chris Coppola (Inactive) added a comment - Updated based on f2f conversation in Chicago.
          Hide
          ewestfal Eric Westfall added a comment - - edited

          This was discussed in the TRC. Kuali Student is on Spring 2.5 so they are currently running Rice on a version of Spring that Rice hasn't been tested on. Impact should be low to the kuali applications and effort should be trivial.

          Show
          ewestfal Eric Westfall added a comment - - edited This was discussed in the TRC. Kuali Student is on Spring 2.5 so they are currently running Rice on a version of Spring that Rice hasn't been tested on. Impact should be low to the kuali applications and effort should be trivial.
          Hide
          coppola Chris Coppola (Inactive) added a comment -

          Targeting for the v1.1 release. This was unanimously agreed to by the roadmap working group in Chicago.

          Show
          coppola Chris Coppola (Inactive) added a comment - Targeting for the v1.1 release. This was unanimously agreed to by the roadmap working group in Chicago.
          Hide
          ewestfal Eric Westfall added a comment -

          Changing the title of this to Spring 3.0 upgrade. TRC discussed this and agreed to move to this version of Spring for 1.1. Change has already been made in the 1.1 codebase.

          As for Spring 2.5, Rice 1.0.3 upgraded to that version of the framework.

          Show
          ewestfal Eric Westfall added a comment - Changing the title of this to Spring 3.0 upgrade. TRC discussed this and agreed to move to this version of Spring for 1.1. Change has already been made in the 1.1 codebase. As for Spring 2.5, Rice 1.0.3 upgraded to that version of the framework.
          Hide
          jcoltrin Jessica Coltrin (Inactive) added a comment -

          Checked the latest pom.xml file in the 2.0 code and we're now on Spring 3.0.5, so I'm going to go ahead and resolved.

          Show
          jcoltrin Jessica Coltrin (Inactive) added a comment - Checked the latest pom.xml file in the 2.0 code and we're now on Spring 3.0.5, so I'm going to go ahead and resolved.

            People

            • Assignee:
              ewestfal Eric Westfall
              Reporter:
              coppola Chris Coppola (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: