Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 0.9.1, Core - 0.9.1
    • Component/s: Documentation
    • Labels:
      None
    • Rice Module:
      Rice Core

      Description

      Xalan gives us problems on Java 1.6 on Mac during Rice startup. Here is a thread which describes the issue and the proposed solution. We need to make sure we have this in our FAQ as well:

      http://mail-archives.apache.org/mod_mbox/xmlgraphics-fop-users/200702.mbox/%3Cloom.20070228T040726-812@post.gmane.org%3E

      Essentially, the java jdk includes a java 1.4 compatability jar which needs to be removed in order to get rid of this problem.

        Attachments

          Issue Links

            Activity

            Hide
            natjohns Nate Johnson (Inactive) added a comment -

            I can't for the life of me find where to download java 1.6 (or 6.0) for mac. From everything I am looking at, it is still in beta. I would have to guess that the solution would be similar to my comment below (which is to delete the compibility jar file):

            It appears that Apple decided to include old libraries like crimson and xalan, among others, with java 1.5. The only solution is to removed the old compatibility jars from the JDK. This seems like a bad solution to me, but this is also what Spring recommends in its FAQs. See http://static.springframework.org/spring-ws/site/faq.html.

            It will be in:
            /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Classes/.compatibility

            Show
            natjohns Nate Johnson (Inactive) added a comment - I can't for the life of me find where to download java 1.6 (or 6.0) for mac. From everything I am looking at, it is still in beta. I would have to guess that the solution would be similar to my comment below (which is to delete the compibility jar file): It appears that Apple decided to include old libraries like crimson and xalan, among others, with java 1.5. The only solution is to removed the old compatibility jars from the JDK. This seems like a bad solution to me, but this is also what Spring recommends in its FAQs. See http://static.springframework.org/spring-ws/site/faq.html . It will be in: /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Classes/.compatibility
            Hide
            agodert Aaron Godert (Inactive) added a comment -

            Did you put these out in the wiki some place?

            Show
            agodert Aaron Godert (Inactive) added a comment - Did you put these out in the wiki some place?
            Hide
            agodert Aaron Godert (Inactive) added a comment -
            Show
            agodert Aaron Godert (Inactive) added a comment - Please put your docs on this here: https://test.kuali.org/confluence/display/KULRICE/Known+Issues

              People

              • Assignee:
                natjohns Nate Johnson (Inactive)
                Reporter:
                ewestfal Eric Westfall
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1 hour
                  1h
                  Remaining:
                  Remaining Estimate - 1 hour
                  1h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified