Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-2302

Allow AbstractLookupableHelperServiceImpl to use serivce locators instead of injection.

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0
    • Component/s: Development
    • Labels:
      None
    • Similar issues:
      KULRICE-2110Remove dependency injection between services in Rice modules and use Service Locators instead
      KULRICE-7779Allow overriding a specific button in Uif-InquiryFooter instead of using nested beans
      KULRICE-10374Allow for Bootstrap glyphs and custom glyphs to be used in action fields
      KULRICE-378Document proper service location and dependency injection practices that rice client devs should use (do this during KRA retreat week - June 11)
      KULRICE-7108javadoc fix for AbstractLookupableHelperServiceImpl
      KULRICE-3405Add support for injecting a values finder object into ControlDefinition
      KULRICE-11840TermRepositoryService Spring injected needed
      KULRICE-10079Allow for light table to be used in details
      KULRICE-6772ModuleConfigurers should not allow injection of moduleName and validRunModes
      KULRICE-12613KRAD : Inject Spring Beans into KRAD and DD using SpEL.
    • Rice Module:
      KNS

      Description

      We ran into problems with this when attempting to implement custom lookupable helpers in KEW. The problem is that we don't have easy access (at the current time) to KNS's Spring context so we don't have an easy way to make the kuali lookup helper our Parent bean. I could see this as a general problem for any Rice application. KFS handled this by essentially overriding the "lookupableHelperService" and injecting it.

      A better solution would be to have AbstractLookupableHelperServiceImpl use KNSServiceLocator in those cases where an explicit service is not injected.

        Issue Links

          Activity

          Eric Westfall added a comment -

          This has been committed to 0.9.4.

          Ailish Byrne added a comment -

          just to make sure it's clear - we didn't purposefully handle this by overriding the lookuapbleHelperSevice - we had to do that because of the rice dependency injection issues - so we didn't notice this problem this is a good thing to be aware of for when the dependency injection issues are fixed - we'll have to correct


            People

            • Assignee:
              Eric Westfall
              Reporter:
              Eric Westfall
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 30 minutes
                30m
                Remaining:
                Remaining Estimate - 30 minutes
                30m
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Structure Helper Panel