Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.1
    • Component/s: Unit Testing
    • Labels:
      None
    • Similar issues:
      KULRICE-13862Improve the KIM unit tests
      KULRICE-5086Fix broken Kim tests in 1.0.3.2
      KULRICE-2269Write Unit Tests for KIM Services
      KULRICE-2121Fix and finish Ignored KIM tests
      KULRICE-2336Create KIM Test data and unit tests
      KULRICE-3747Unit Test Failures in 1.0.1.1
      KULRICE-7399fix unit test failures
      KULRICE-1692Fix EDocLiteXPathTest unit test
      KULRICE-5343Create additional unit tests for KIM
      KULRICE-2656Examine unit test failures, fix as many as you can, catalog the ones that need more work to solve
    • Rice Module:
      KIM

      Description

      The following error is being caused by a proxy issue where the KimEntityBioDemographics object is not initialized and doesn't exist.

      org.apache.ojb.broker.PersistenceBrokerException: Error invoking method getEntityId
      at org.apache.ojb.broker.core.proxy.AbstractIndirectionHandler.invoke(AbstractIndirectionHandler.java:363)
      at org.kuali.rice.kim.bo.entity.impl.KimEntityBioDemographicsImpl$$EnhancerByCGLIB$$5a99d2d6.getEntityId(<generated>)
      at org.kuali.rice.kim.bo.entity.dto.KimEntityBioDemographicsInfo.<init>(KimEntityBioDemographicsInfo.java:64)
      at org.kuali.rice.kim.bo.entity.dto.KimEntityInfo.<init>(KimEntityInfo.java:78)
      at org.kuali.rice.kim.service.impl.IdentityServiceImpl.convertEntityImplToInfo(IdentityServiceImpl.java:220)
      at org.kuali.rice.kim.service.impl.IdentityServiceImpl.lookupEntityInfo(IdentityServiceImpl.java:180)
      at org.kuali.rice.kim.test.service.IdentityServiceTest.testLookupEntityInfo(IdentityServiceTest.java:180)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.junit.internal.runners.TestMethod.invoke(TestMethod.java:59)
      at org.junit.internal.runners.MethodRoadie.runTestMethod(MethodRoadie.java:98)
      at org.junit.internal.runners.MethodRoadie$2.run(MethodRoadie.java:79)
      at org.junit.internal.runners.MethodRoadie.runBeforesThenTestThenAfters(MethodRoadie.java:87)
      at org.junit.internal.runners.MethodRoadie.runTest(MethodRoadie.java:77)
      at org.junit.internal.runners.MethodRoadie.run(MethodRoadie.java:42)
      at org.junit.internal.runners.JUnit4ClassRunner.invokeTestMethod(JUnit4ClassRunner.java:88)
      at org.kuali.rice.test.runners.RiceUnitTestClassRunner.invokeTestMethod(RiceUnitTestClassRunner.java:44)
      at org.junit.internal.runners.JUnit4ClassRunner.runMethods(JUnit4ClassRunner.java:51)
      at org.junit.internal.runners.JUnit4ClassRunner$1.run(JUnit4ClassRunner.java:44)
      at org.junit.internal.runners.ClassRoadie.runUnprotected(ClassRoadie.java:27)
      at org.junit.internal.runners.ClassRoadie.runProtected(ClassRoadie.java:37)
      at org.junit.internal.runners.JUnit4ClassRunner.run(JUnit4ClassRunner.java:42)
      at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:62)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:140)
      at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:127)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:177)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:338)
      at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:997)
      Caused by: java.lang.NullPointerException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.ojb.broker.core.proxy.AbstractIndirectionHandler.invoke(AbstractIndirectionHandler.java:353)
      ... 33 more

        Activity

        Jeremy Hanson added a comment -

        These have been fixed by checking ObjectUtils.isNull on the bioDemographics and privacyPreferences in the KimEntityImpl class.


          People

          • Assignee:
            Jeremy Hanson
            Reporter:
            Jeremy Hanson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Structure Helper Panel