Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-3679

Improve the performance of qualified role matching in KIM

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: KC Release 2.0, 1.0.2
    • Component/s: Development
    • Labels:
      None
    • Similar issues:
      KULRICE-13235Clear up the KIM qualifier question as to whether they should match by wildcard
      KULRICE-2353KIM Role Service Test
      KULRICE-8448Improve Role Performance
      KULRICE-9165Person document not displaying role qualifiers
      KULRICE-4886Role qualifiers values cannot include whitespace
      KULRICE-12341Performance issues opening large roles
      KULRICE-1470KIM Qualified Role with multiple qualifications
      KULRICE-11714KIM Performance: check whether role members need to be sorted
      KULRICE-3848Delegation membership check not working for non-qualified roles
      KULRICE-7082KIM role document not handling missing qualifiers on role members
    • Rice Module:
      KIM
    • Application Requirement:
      KC

      Description

      See coeus issue KRACOEUS-2983

      KC will implement and we will do a code review

        Issue Links

          Activity

          Chitra Chandran added a comment -

          Yes Travis. I just spoke to Terry abt this.

          Jonathan,
          can you let us know when your testing is complete so that we can get rice re-deployed?

          Jonathan Keller added a comment -

          I sent this change to John Walker at CSU who noticed the problem. He confirmed that the nested roles he was testing are now working again.

          I also have little concern over this change since it is essentially reverting to the pre-change behavior in this situation.

          Chitra Chandran added a comment -

          I take it then that we can start the re-deploy process.

          Travis, it would be great if we can get this change in time for our REG rebuild tonight.

          Thanks,
          Chitra

          Jeremy Hanson added a comment -

          Can this issue be resolved?

          Jonathan Keller added a comment -

          I think so. The patch appears to correct the issue.


            People

            • Assignee:
              Chitra Chandran
              Reporter:
              Eric Westfall
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Structure Helper Panel