Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-3849

Rice sources not downloading with maven eclipse plugin

    Details

    • Type: Bug Fix Bug Fix
    • Status: Open Open
    • Priority: Trivial Trivial
    • Resolution: Unresolved
    • Affects Version/s: 1.0.1
    • Fix Version/s: Backlog
    • Component/s: Configuration
    • Labels:
    • Environment:
      maven 2.0.9 jdk 1.6.0_14
    • Similar issues:
      KULRICE-1566Missing source in latest (1/25) rice-kns SNAPSHOT update
      KULRICE-902KEW source code should be added to the Maven repository
      KULRICE-1654Switch 0.9.3 project to Maven eclipse:eclipse plugin and update docs
      KULRICE-1473Switch from the Maven Assembly plugin to the Ant maven plugin for packaging tasks
      KULRICE-1315Latest source code isn't in Maven repository
      KULRICE-9952Setup Saucelabs maven plugin
      KULRICE-12979Test git with maven-release-plugin
      KULRICE-6798Branch strip-bom-maven-plugin and Add it to the Kuali Rice POM
      KULRICE-3378Upgrade the maven-deploy-plugin version to 2.4 and remove individual rice maven modules from deploying jar files
      KULRICE-4877createproject.groovy still generates a project which does not compile successfully in Eclipse
    • Rice Module:
      Rice Core
    • Application Requirement:
      KS

      Description

      when using the maven-eclipse-plugin to download sources it would complain that rice sources could not be found.
      the specific command is here http://maven.apache.org/plugins/maven-eclipse-plugin/examples/attach-library-sources.html

      after some testing, i was able to get it to work by modifying my local repository pom.
      as an example, the api current rice pom look like (this is affecting impl and there may be others)

      <name>Kuali Rice API</name>
      <modelVersion>4.0.0</modelVersion>
      <parent>
      <groupId>org.kuali.rice</groupId>
      <artifactId>rice</artifactId>
      <version>1.0.1</version>
      </parent>
      <artifactId>rice-api</artifactId>

      I changed it to

      <name>Kuali Rice API</name>
      <modelVersion>4.0.0</modelVersion>
      <groupId>org.kuali.rice</groupId>
      <artifactId>rice-api</artifactId>
      <version>1.0.1</version>
      <packaging>jar</packaging>

      <parent>
      <groupId>org.kuali.rice</groupId>
      <artifactId>rice</artifactId>
      <version>1.0.1</version>
      </parent>

      and that fixed it.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Richard Diaz (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Time Tracking

              Estimated:
              Original Estimate - 20 minutes
              20m
              Remaining:
              Remaining Estimate - 20 minutes
              20m
              Logged:
              Time Spent - Not Specified
              Not Specified

                Structure Helper Panel