Details

    • Type: Bug Fix Bug Fix
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.2.1, KC Release 3.0, 1.0.3
    • Fix Version/s: 1.0.2.1, KC Release 3.0, 1.0.3
    • Component/s: Development
    • Labels:
      None
    • Similar issues:
      KULRICE-7225Fix iframe resize problem in chrome
      KULRICE-5989Cross domain iFrame resize transition fix
      KULRICE-5988Iframe resize issue in Chrome
      KULRICE-8333Fix the iframe resizing script so we do not see double scroll bars and at the same time the KRMS screens are not affected.
      KULRICE-9829Chrome back problems iframes (mainly in lightboxes)
      KULRICE-5688Fix the iframe title ("edoc")
      KULRICE-9830IE back problems (iframes in lightboxes)
      KULRICE-8297IdentityRoleBlanketAppLegacyIT.testBlanketApprove iframe problem
      KULRICE-7833After iFrame removal support - do not allow KRAD content to be in an iframe
      KULRICE-11950Prevent resizing jump on lightbox
    • Rice Module:
      KNS
    • Application Requirement:
      KC

      Description

      In certain browsers the portlet iframe does not expand vertically & horizontally in a correct fashion. Also, we have had infinite expanding problems in the past.

        Issue Links

          Activity

          Travis Schneeberger added a comment -

          The patch attached addresses the vertical expanding. There is still some work to do.

          1) need to test out more browsers.
          2) need to test the default behavior when javascript is off.
          3) the script should be externalized rather than embedded in a tag file.
          4) I currently have a hardcoded value to make up for browser differences in the way scrollHeight is calculated - I should figure out what these differences are rather than using a random 20px. For example: It might be as simple as just adding the margin value or something.
          5) Figure out the horizontal scrolling problems. I suspect that there is some naughty css styles/malformed html causing these problems. Need to figure this out.

          Travis Schneeberger added a comment -

          The former resize script was just weird to put it mildly. It used window.setInterval() which is what caused the infinite resize problems. Really, I don't understand why you would need to do this... Seems like you could just use certain events to do resizing such as onload/onresize... Anyway, my script will not have these problems.

          As for the vertical expanding problem - That was caused by a float: left css style. By removing that along with my other changes everything works fine.

          Travis Schneeberger added a comment -

          The attached patch has been completely reworked. Keeping it attached to the jira for historical purposes.

          Eric Westfall added a comment -

          Travis, you're currently the assignee on this one. Is that still accurate? If so, how long do you think it would take to integrate the patch? I'm working on estimates for the 1.0.3 work right now.

          Travis Schneeberger added a comment -

          I'm testing the fix right now - should close it out today if all goes well.

          Travis Schneeberger added a comment -

          looks like some cross browser issues slipped through the cracks in chrome & IE. I'll be working on a fix.


            People

            • Assignee:
              Travis Schneeberger
              Reporter:
              Travis Schneeberger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Structure Helper Panel