Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.3
    • Component/s: Configuration
    • Labels:
      None
    • Similar issues:
      KULRICE-3804Make 1.1.0 Java 1.6 compliant
      KULRICE-4877createproject.groovy still generates a project which does not compile successfully in Eclipse
      KULRICE-6041Update documentation stating that we are now 1.6 compliant for both source and compile
      KULRICE-1041Document issues with Java 1.6 on Mac
      KULRICE-5624Evaluate Groovy/Maven compiler choices
      KULRICE-4457rice 1.0.3 fails to compile with java 5 b/c of missing dependency
      KULRICE-7386Rice doesn't compile on JDK 7 on the cli
      KULRICE-9717Add maven plugin for compiling LESS files
      KULRICE-14133Correct Maven dependencies to allow Rice to compile in Java 8
      KULRICE-13990Add github-pull-request-builder-plugin to jenkins

      Description

      Current maven compile plugin:
      <plugin>
      <artifactId>maven-compiler-plugin</artifactId>
      <configuration>
      <source>1.5</source>
      <target>1.5</target>
      <!-- impl module is huge and requires at least 768m to compile -->
      <fork>true</fork>
      <meminitial>256</meminitial>
      <maxmem>1024</maxmem>
      </configuration>
      </plugin>

      the target needs to be 1.6 for the 1.0.3 branch. I think it should have been 1.6 for the 1.0.2 branch so I'm not sure what happened there.

        Activity

        Hide
        Garey Taylor added a comment -

        Done.

        Show
        Garey Taylor added a comment - Done.

          People

          • Assignee:
            Garey Taylor
            Reporter:
            Garey Taylor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Structure Helper Panel