Details

    • Type: Bug Fix
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: Backlog
    • Component/s: Development
    • Labels:
    • Rice Module:
      KNS
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      Someone posted this awhile back on the rice collab list. I'm not sure if it's still a problem or not but I can't recall us doing anything to address it. The person who posted it was Kevin McOmber for univeristy of arizona. Details below:

      From: Kevin McOmber
      Sent: Friday, November 06, 2009 3:30 PM
      To: (financial.technical.collab@kuali.org)
      Subject: HTML padded with spaces breaking hyperlink

      I created a new field in PaymentDetail business object as type String. The field holds a value like this:

      "<a href="https://dev.fso.arizona.edu/isw/webservices/docuware.asp?table=ap&idtype=dwdocid&idvalue=10201767">10201767</a>"

      The Attribute Definition I am using is as follows:
      <bean id="PaymentDetail-docuwareLink" parent="PaymentDetail-docuwareLink-parentBean" />
      <bean id="PaymentDetail-docuwareLink-parentBean" abstract="true" parent="AttributeDefinition">
      <property name="name" value="docuwareLink" />
      <property name="label" value="Payment Detail ID" />
      <property name="shortLabel" value="Payment Detail ID" />
      <property name="maxLength" value="128" />
      <property name="control">
      <bean parent="TextControlDefinition" p:size="128" />
      </property>
      </bean>

      When I open the document I see something like this:

      <a href="https://dev.fso.arizona.edu
      /isw/webservices/docuware.asp?tab
      le=ap&idtype=dwdocid&idvalue=102
      01767">10201767</a>

      But I should just have a link with the value of 10201767. If I open firebug and remove some of the spaces between <span id="docuwareLink.div"> and my anchor tag then the hyperlink works and looks fine. I do not understand why there are 37 spaces between these two pieces of html code. Is there a way to remove or control this for a maintenance document in KFS?

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              ewestfal Eric Westfall
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: