Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-4573

blanket approve a kim person doc gets stuck in enroute status

    Details

    • Type: Bug Fix Bug Fix
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: KC Release 3.0, 1.0.3
    • Fix Version/s: KC Release 3.0, 1.0.3
    • Component/s: Development
    • Labels:
      None
    • Similar issues:
      KULRICE-7744MAINTENANCE: New person record stuck in ENROUTE status
      KULRICE-8644When trying to copy certain permissions, doc gets stuck 'Enroute'
      KULRICE-12178AFT Failure Identity Blanket Approvals go to ENROUTE rather than FINAL
      KULRICE-9051AFT Failure WorkFlow Route Rules Blanket Approval submit status results in Enroute, not Final
      KULRICE-5484Rice Dev: Trying to Open Blanket Approved Person doc, doc doesn't render
      KULRICE-12429Editing PeopleFlow Document Stuck in EnRoute Status
      KULRICE-4083ALLOW_ENROUTE_BLANKET_APPROVE_WITHOUT_APPROVAL_REQUEST_IND doesn't appear to work the way it's being described.
      KULRICE-4430Cannot save/submit/blanket approve a person document with new Affiliation and Employment Info
      KULRICE-3341If a document routes to a node with no members then the document gets "stuck" there
      KULRICE-9002Illegal Argument Exception on KIM Person w/Phone Number in Invalid Format
    • Rice Module:
      KIM
    • Application Requirement:
      KC
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      see linked issue

        Activity

        Jeremy Hanson added a comment -

        Just a note that I just tried this in rice, and the person document did go to final. I'll try loading up KC and see what happens.

        Travis Schneeberger added a comment -

        thanks it could be our workflow is out of wack somehow....

        Jeremy Hanson added a comment -

        Just tried it in KC (bundled) and it also goes to final there. I don't believe I'm doing anything differently...

        Going to create new person link.
        filling in Description, principal name

        setting to faculty, bloomington campus default, setting employee id, Primary, Active, Professional, and setting a base salary.
        Add a primary name and set to default

        Then blanket approve

        Then the document goes to final.

        I'm logged in as quickstart when this happens. One thing I see in the route log image on KCINFR-104, is the document was initiated by Geoff McGregor, so maybe there is some permission issue? I'll try logging in as him and try it.

        Travis Schneeberger added a comment -

        looks like this issue is now fixed...neither lisa or I can reproduce the issue. Not what what changed. We'll keep and eye on things and reopen if needed.


          People

          • Assignee:
            Jeremy Hanson
            Reporter:
            Travis Schneeberger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 day
              1d
              Remaining:
              Remaining Estimate - 1 day
              1d
              Logged:
              Time Spent - Not Specified
              Not Specified

                Structure Helper Panel