Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-4777

Fix workflow for Travel Request (sample travel app)

    Details

    • Type: Bug Fix Bug Fix
    • Status: Open Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 1.0.3
    • Fix Version/s: Backlog
    • Component/s: Development
    • Labels:
    • Similar issues:
      KULRICE-10045KRAD Sample App: Traveler Authorization Request Page. Lookups throw BadSqlGrammerException
      KULRICE-4692manual test cases for the travel sample app
      KULRICE-5651Create KRAD Version of Sample Travel App
      KULRICE-5652Create KRAD Version of Create New Sample Application Travel Request Document
      KULRICE-11470Create Yes/No Dialog sample in Travel App
      KULRICE-11419KRAD Sample Travel App: Move unnecessary screens into their own menu section
      KULRICE-4535Extract travel "sample app" out into it's own maven module
      KULRICE-10208Fix up missing travel sample app data resulting from JPA conversion of sample app
      KULRICE-4795Create sample travel app that uses war overlays and embedded mode
      KULRICE-11418KRAD Sample Travel App: Add field requirements and standardize labels
    • Rice Module:
      KNS
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      There are some apparent issues (and some suspected ones) with the way the routing rules for the sample travel app are set up, and the way the workflow is playing out:

      • rule 'TravelRequest.Supervisor' is using rule template 'TravelerRequest-TravelerRouting'
      • rule 'TravelRequest.FiscalOfficer' is using rule template 'TravelRequest-SupervisorRouting'
      • the rule for template 'TravelRequest-AccountRouting' is named '659D86718DD514C7E0404F8189D877C3' and doesn't appear to be functioning
        • in my test, the fiscal officer never had to approve
        • looking at the rule template for TravelRequest-AccountRouting, it has the AccountAttribute rule attribute, but using the 'Routing Report' feature, the attribute isn't showing up as it should.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Peter Giles (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Structure Helper Panel