Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.0-m1, 2.3
    • Component/s: Development, Roadmap
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Rice Module:
      KRAD
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required
    • Include in Release Notes?:
      Yes

      Description

      The following options need to be implemented for the LookupView:

      disable search buttons - disables the footer group on the criteria group
      hide return links - disables rendering of the return column on result group
      suppress actions - disables rendering of the actions column on result group
      show maintenance links - indicates whether the maintenance new/copy/edit/delete should be shown
      lookup criteria enabled - indicates whether the criteria should be shown
      supplemental actions enabled - indicates whether actions other than maintenance should be enabled
      header bar enabled - indicates whether the header menu bar should be rendered

        Attachments

          Issue Links

            Activity

            Hide
            jcoltrin Jessica Coltrin (Inactive) added a comment -

            double-tagging with 2.0.0-b3 for review.

            Show
            jcoltrin Jessica Coltrin (Inactive) added a comment - double-tagging with 2.0.0-b3 for review.
            Hide
            jkneal Jerry Neal (Inactive) added a comment -

            FYI - I believe most of these are already implemented but we should verify.

            Also, I believe I mentioned this to Claus I would like us to consider implementing a naming convention for properties that determine whether something is displayed. There are all kinds of variations which you see many of in the lookup view 'show', 'hide', 'render', 'display', 'enable', ... It would great if we could do everything as 'render*'. We have used this in many places in the UIF. So I would recommend we change all these properties to renderSomething. This might flip the logic for some of them (for example hideReturnLinks will become renderReturnLinks and where false was being passed true will need to be).

            Jerry

            Show
            jkneal Jerry Neal (Inactive) added a comment - FYI - I believe most of these are already implemented but we should verify. Also, I believe I mentioned this to Claus I would like us to consider implementing a naming convention for properties that determine whether something is displayed. There are all kinds of variations which you see many of in the lookup view 'show', 'hide', 'render', 'display', 'enable', ... It would great if we could do everything as 'render*'. We have used this in many places in the UIF. So I would recommend we change all these properties to renderSomething. This might flip the logic for some of them (for example hideReturnLinks will become renderReturnLinks and where false was being passed true will need to be). Jerry
            Hide
            samuel Samuel Holtzkampf (Inactive) added a comment -

            supplemental actions enabled was used as an internal flag to help with the jsp rendering. This was set by in KualiLookupAction and used in KualiLookup.jsp. Not needed in KRAD.

            Show
            samuel Samuel Holtzkampf (Inactive) added a comment - supplemental actions enabled was used as an internal flag to help with the jsp rendering. This was set by in KualiLookupAction and used in KualiLookup.jsp. Not needed in KRAD.

              People

              • Assignee:
                samuel Samuel Holtzkampf (Inactive)
                Reporter:
                jkneal Jerry Neal (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: