Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-5925

Lookup return functionality is not working when used on Workflow search attributes

    Details

    • Type: Bug Fix Bug Fix
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 2.1.3
    • Component/s: Development
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Similar issues:
      KULRICE-7546When doing a lookup from Detailed Doc Search, you are returned to Basic Doc Search
      KULRICE-10892Multi Value Return lookup not working when using server paging
      KULRICE-13923Lookup return doesn't work when using a nested lookup within a dialog
      KULRICE-7483make doc search work like other lookups in terms of result limits
      KULRICE-12911Rule lookup by attributes not working
      KULRICE-13200Delegation Rule Lookup: No values returned on search
      KULRICE-13248Error on group lookup when searching by KIM type on groups with attributes
      KULRICE-1272On the Workgroup create/edit page when a lookup is used to find a user/group for the AdHoc Route section the Workgroup Entry page does not function
      KULRICE-883Using a Saved Search that contains searchable attributes where the searchable attributes values may contain a colon or comma error out
      KULRICE-6721Document search does not work properly with KNS Attribute Definitions
    • Rice Module:
      KEW
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      Attempting to return a looked-up value to the main search page does not work as expected with workflow search attributes. Looks like the XML utility (XMLAttributeUtils) used for establishing the field conversion mapping has a bug.

      Pls see linked issue for more details.

        Activity

        Hide
        Sona Sona (Inactive) added a comment - - edited

        Just to make sure that I am looking at the right thing. I went to http://test.kc.kuali.org/. I am looking at the Developement Proposal Lookup (Researcher tab -> Search Proposals). The quick search for Proposal Type, Proposal State and Sponsor Code work but Sponsor Name, Lead Unit and Lead Unit Name do not work. Are these the screens we are talking about? Could you attach a screen shot too? Could you also give the steps to reproduce this issue.

        Show
        Sona Sona (Inactive) added a comment - - edited Just to make sure that I am looking at the right thing. I went to http://test.kc.kuali.org/ . I am looking at the Developement Proposal Lookup (Researcher tab -> Search Proposals). The quick search for Proposal Type, Proposal State and Sponsor Code work but Sponsor Name, Lead Unit and Lead Unit Name do not work. Are these the screens we are talking about? Could you attach a screen shot too? Could you also give the steps to reproduce this issue.
        Hide
        Gayathri Athreya added a comment -

        Hi Sona, I have asked for more information on the jira. Will get back to you once I hear more. Thanks.

        Show
        Gayathri Athreya added a comment - Hi Sona, I have asked for more information on the jira. Will get back to you once I hear more. Thanks.
        Hide
        Sona Sona (Inactive) added a comment -

        Hi Gayathri,
        I tried the docSearch(DocSearch) with documentType 'ProposalDevelopmentDocument' and the fields that are being talked about in the linked jira (aggregator,budget creator etc) make more sense than the steps that I have listed above. I am attaching a screen shot of what I see. Looks to me that the linked jira is no longer an issue but I will wait for you to verify.

        Show
        Sona Sona (Inactive) added a comment - Hi Gayathri, I tried the docSearch(DocSearch) with documentType 'ProposalDevelopmentDocument' and the fields that are being talked about in the linked jira (aggregator,budget creator etc) make more sense than the steps that I have listed above. I am attaching a screen shot of what I see. Looks to me that the linked jira is no longer an issue but I will wait for you to verify.
        Hide
        Gayathri Athreya added a comment -

        Hi Sona, I have tried the doc search and the prop dev lookups and I am not able to figure out what the issue is, neither can some of the functional people I have spoken to. I am just waiting for the creator of the jira to respond. If I do not hear back soon, you can go ahead and resolve it with a "will not fix". Will let you know. Thanks.

        Show
        Gayathri Athreya added a comment - Hi Sona, I have tried the doc search and the prop dev lookups and I am not able to figure out what the issue is, neither can some of the functional people I have spoken to. I am just waiting for the creator of the jira to respond. If I do not hear back soon, you can go ahead and resolve it with a "will not fix". Will let you know. Thanks.
        Hide
        Sona Sona (Inactive) added a comment -

        Hi Gayathri,
        Would it be ok to consider this issue as a non-issue? Thanks

        Show
        Sona Sona (Inactive) added a comment - Hi Gayathri, Would it be ok to consider this issue as a non-issue? Thanks
        Hide
        Gayathri Athreya added a comment -

        Yes Sona, please go ahead and resolve as a "won't fix". I have not heard anything back from the jira creator and the functional folks are not able to recreate either. Thanks.

        Show
        Gayathri Athreya added a comment - Yes Sona, please go ahead and resolve as a "won't fix". I have not heard anything back from the jira creator and the functional folks are not able to recreate either. Thanks.

          People

          • Assignee:
            Sona Sona (Inactive)
            Reporter:
            Chitra Chandran
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Structure Helper Panel