Uploaded image for project: 'Kuali Rice Development'
  1. Kuali Rice Development
  2. KULRICE-6875

user 'khuntley' is not authorized to take action 'start' on targets of type 'CustomerStatementAction' in AR module.

    Details

    • Type: Bug Fix
    • Status: Closed
    • Priority: Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: Development
    • Labels:
      None
    • Rice Module:
      KRAD
    • Application Requirement:
      KFS
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      When initiating a document (like Cash control) it looks at PermissionServiceImpl class and getRoleIdsForPermissions method that checks the table KRIM_ROLE_PERM_T for roleids as commented in KFSMI-7407. But when user is taking action (permission name: Use Screen) the method principalHasRole(principalId, roleIds, qualification, true) method is return false in RoleServiceImpl class. Using role id and principlaId it tries to retrieve the rows from KRIM_ROLE_MBR_T but there are no records in that table for the given role id 12 and principlaid 6162122038 (khuntley) as commented in KFSMI-7369.

      Not sure whether in both places it should be using PermissionServiceImpl class methods.

        Attachments

          Issue Links

            Activity

            jjhanso Jeremy Hanson added a comment -

            The problem is happening because RoleTypeService changed. The hasApplicationRole method has been changed to hasDerivedRole.

            Because AccountsReceivableOrganizationDerivedRoleTypeServiceImpl (wow that is a long name) doesn't have a hasDerivedRole method, it falls back to the standard hasDerivedRole from the RoleTypeServiceBase class, and returns false.

            So, the solution is to change your hasApplicationRole methods in your RoleTypeServices to hasDerivedRole.


              People

              • Assignee:
                jjhanso Jeremy Hanson
                Reporter:
                mksalem Muddu Salem
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: