Details

    • Type: Bug Fix
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.2
    • Component/s: Development
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      It appears to still be an issue where asm 1.5.3 dependencies are creeping into client applications which depend on Rice. This causes major problems since asm 3.3.1 is the version we are supposed to be using and asm 1.5.3 breaks Apache CXF functionality (and, subsequently, web services).

      Our dependency to asm-1.5.3.jar is coming in through our dependency on OJB. So I say we add this to the list of exclusions on OJB in the dependencyManagement section of the root Kuali Rice pom file.

        Attachments

          Activity

          Hide
          ewestfal Eric Westfall added a comment -

          I went ahead and moved this one to 2.1 backlog since it's not super critical for 2.0.2

          Show
          ewestfal Eric Westfall added a comment - I went ahead and moved this one to 2.1 backlog since it's not super critical for 2.0.2

            People

            • Assignee:
              sonam Sona Sona (Inactive)
              Reporter:
              ewestfal Eric Westfall
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: