Details

    • Type: Bug Fix Bug Fix
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1.1
    • Component/s: Database
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Similar issues:
      KULRICE-11293MySQL scripts for 2.1.3 - 2.2.1 and 2.1 - 2.2 upgrade do not work
      KULRICE-8402Apply database scripts to the 2.1 and 2.2 master databases
      KULRICE-8447Apply Backdoor Restriction database scripts to the 2.1 and 2.2 master databases
      KULRICE-8462Apply database scripts to the 2.1 and 2.2 mysql master databases
      KULRICE-8411Apply database scripts to the 2.1 and 2.2 master databases
      KULRICE-13474Validate that the Rice upgrade scripts execute and produce the correct final schema when run against the previous version of the database
      KULRICE-6600Rice 2.0 upgrade scripts coming with KIM bootstrap data need to be consistent w.r.t ID generation
      KULRICE-8552Apply populate group database scripts to the 2.1 and 2.2 master databases
      KULRICE-7267Rice upgrade scripts will not work with "real" data
      KULRICE-8592Apply Completion Action Requested database scripts to the 2.1 master database
    • Rice Module:
      KIM
    • Application Requirement:
      KFS
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      The Rice upgrade scripts contain this code. This would drop and re-initialize the role-permission sequence. This was in use in Rice 1.x per the OJB settings. If any institution had been using it, including this in the standard upgrade scripts could cause problems with the KIM role document.

      I'm removing this from the KFS upgrade scripts.

      DECLARE temp NUMBER;
      BEGIN
          SELECT COUNT(*) INTO temp FROM user_sequences WHERE sequence_name = 'KRIM_ROLE_PERM_ID_S';
          IF temp > 0 THEN EXECUTE IMMEDIATE 'DROP SEQUENCE KRIM_ROLE_PERM_ID_S'; END IF;
      END;
      /
      CREATE SEQUENCE KRIM_ROLE_PERM_ID_S INCREMENT BY 1 START WITH 10000 NOMAXVALUE NOCYCLE NOCACHE ORDER
      /
      

        Activity

        Hide
        Peter Giles (Inactive) added a comment -

        Ooops, it seems that should have been executed against the master, but not added to the upgrade scripts. I've removed those scripts & snippets from the final rollups.

        Show
        Peter Giles (Inactive) added a comment - Ooops, it seems that should have been executed against the master, but not added to the upgrade scripts. I've removed those scripts & snippets from the final rollups.

          People

          • Assignee:
            Peter Giles (Inactive)
            Reporter:
            Jonathan Keller
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Structure Helper Panel