Kuali Rice Development
  1. Kuali Rice Development
  2. KULRICE-7430

Collection with in subcollection - Add row should not be added to the collection if it has errors

    Details

    • Type: Bug Fix Bug Fix
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2
    • Component/s: Development
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Similar issues:
      KULRICE-12840Collection row with subcollection - detail displayed in one row
      KULRICE-9838Collection Creates Extra Row
      KULRICE-7121error on deleting a row from a sub collection
      KULRICE-7428Duplicate error messages on collections within a subcollection
      KULRICE-9816New collection rows are not set to dirty
      KULRICE-7490Highlight collection when hovering on add button
      KULRICE-8087collection property "includeLineSelectionField" should ignore addLine row
      KULRICE-7468Collections UI - autosorting should not be on by default (in adding to collections/sub-collections)
      KULRICE-6333Adding to a sub-collection results in a new empty line on the last sub-collection off the primary collection
      KULRICE-6291title of lookup for adding multiple to a collection group should be generic
    • Rice Module:
      KRAD
    • Application Requirement:
      KS
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      It's working fine for collections but not for collections within a subcollections.

      Uif-Disclosure-StackedCollectionSection
      Uif-Disclosure-StackedCollectionSubSection
      Uif-Disclosure-TableSubCollection-WithinSubSection (Add row validating but still adds to collection with errors)

        Activity

        Hide
        Venkat PremChandran (Inactive) added a comment -

        Actually, I noticed it's working fine for REQUIRED validation... I have TimePatternConstraint on a field. If I type 0500 (on focus lost, getting validation error) and click on add, it gets added

        Show
        Venkat PremChandran (Inactive) added a comment - Actually, I noticed it's working fine for REQUIRED validation... I have TimePatternConstraint on a field. If I type 0500 (on focus lost, getting validation error) and click on add, it gets added

          People

          • Assignee:
            Brian Smith (Inactive)
            Reporter:
            Venkat PremChandran (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Structure Helper Panel