Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 2.2.0-m4, 2.2
    • Component/s: Development
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Rice Module:
      KRAD
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required

      Description

      Remaining cleanup items:

      • Need AjaxReturnType on Action component and pass through on actionHandler
      • Remove renderFullView, not needed since we can look at the returnType
      • Rename handleIncidentReport to checkForIncidentReport and cleanup code
      • Remove old ajax code not needed anymore (like updatePageCallback)
      • retrieveComponent has duplicate code with updateComponentHandler
      • Make sure optional parameters are at end of ajax methods and documented as optional on the param tag
      • Redo navigation action links so they don't call handleActionLink but use the standard ajax submit (passing navigateToPageId as submitdata)
      • add constants in krad.variables.js for return types (like "update-page")

      In UifDocumentDefinitions.xml, see if we can change:

      <bean parent="Uif-PrimaryActionButton-Small" p:methodToCall="downloadAttachment"
      p:actionLabel="download attachment" p:title="download attachment"
      p:onClickScript="writeHiddenToForm("skipViewInit", "true");writeHiddenToForm("renderFullView", "false");writeHiddenToForm("unblockUIOnLoading", "true");writeHiddenToForm("actionParameters[selectedLineIndex]", "@

      {#index}

      ");"/>

      to use dataAttributes for the hiddens (besides the one actionParameters which can write the property directly)

      p:dataAttributes="skipViewInit:true, ..."

        Attachments

          Issue Links

            Activity

            Hide
            jkneal Jerry Neal (Inactive) added a comment -

            Might want to add to Action completeCallback as well for code that should run both on success and error

            Show
            jkneal Jerry Neal (Inactive) added a comment - Might want to add to Action completeCallback as well for code that should run both on success and error
            Hide
            jdomeyer Jeff Domeyer (Inactive) added a comment -

            Show/hide inactive records doesn't work.
            UifControllerBase -> toggleInactiveRecordDisplay(...)
            line 295
            String collectionGroupId = request.getParameter(UifParameters.REQUESTED_COMPONENT_ID);
            That parameter is no longer passed, causes a stack trace later.

            Changed it to:
            String collectionGroupId = uifForm.getPostedView().getViewIndex().getCollectionGroupByPath(uifForm.getActionParamaterValue(UifParameters.SELLECTED_COLLECTION_PATH)).getId();

            That at least get's the data back, but the toggling beans in UifFieldDefinitions
            Uif-ShowInactiveCollectionItemsButton
            Uif-HideInactiveCollectionItemsButton

            They both have the same additionalSubmitData, seems like the hide one should have the inverse of what the show one has.

            Even with changing that, seems like it's still busted.

            It looked like this was the jira (revision 34099 in svn) that introduced this regression.

            Show
            jdomeyer Jeff Domeyer (Inactive) added a comment - Show/hide inactive records doesn't work. UifControllerBase -> toggleInactiveRecordDisplay(...) line 295 String collectionGroupId = request.getParameter(UifParameters.REQUESTED_COMPONENT_ID); That parameter is no longer passed, causes a stack trace later. Changed it to: String collectionGroupId = uifForm.getPostedView().getViewIndex().getCollectionGroupByPath(uifForm.getActionParamaterValue(UifParameters.SELLECTED_COLLECTION_PATH)).getId(); That at least get's the data back, but the toggling beans in UifFieldDefinitions Uif-ShowInactiveCollectionItemsButton Uif-HideInactiveCollectionItemsButton They both have the same additionalSubmitData, seems like the hide one should have the inverse of what the show one has. Even with changing that, seems like it's still busted. It looked like this was the jira (revision 34099 in svn) that introduced this regression.
            Hide
            jkneal Jerry Neal (Inactive) added a comment -

            Jeff,

            Would you mind to create a new Jira for this?

            thanks,
            Jerry

            Show
            jkneal Jerry Neal (Inactive) added a comment - Jeff, Would you mind to create a new Jira for this? thanks, Jerry

              People

              • Assignee:
                jkneal Jerry Neal (Inactive)
                Reporter:
                jkneal Jerry Neal (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: