Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.3
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Similar issues:
      KULRICE-5109Upgrade Apache CXF from 2.3.8 to 2.7.0 and wss4j from 1.5.x to 1.6.7
      KULRICE-8466Number of classes using Apache CXF StringUtils instead of Apache Commons StringUtils
      KULRICE-8826Back level version of Jetty for Integration Tests configured
      KULRICE-6352Upgrade from apache cxf 2.3.6 to 2.3.7
      KULRICE-14164Upgrade Apache CXF from 2.7.12 to 3.0.3
      KULRICE-8472Include information on CXF upgrade in release notes
      KULRICE-3377Upgrade CXF version from 2.1.3 to 2.1.5 for KS
      KULRICE-4418cxf upgrade causes incorrect spring version to be brought in in client applications.
      KULRICE-1309Turnkey Upgrades
      KULRICE-4399As a part of the dependency upgrade for 1.1 upgrade Jetty to version 7
    • Rice Module:
      Rice Core, KSB
    • Application Requirement:
      Rice
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Review Completed

      Description

      As a part of the cxf upgrade jetty should have been upgraded in: https://svn.kuali.org/repos/rice/trunk/it/pom.xml

      from our pom.xml:

          <!-- decrease jetty version for it tests because we are using an old version of cxf -->
          <jetty.version>7.4.5.v20110725</jetty.version>
      

      The 2.7.0 version of the cxf-rt-transports-http-jetty lib uses version 8.1.7.v20120910 of jetty.

        Issue Links

          Activity

          Hide
          Jessica Coltrin (Inactive) added a comment -

          assigning to Peter to review this change at KTI & TRC.

          Show
          Jessica Coltrin (Inactive) added a comment - assigning to Peter to review this change at KTI & TRC.
          Hide
          Jessica Coltrin (Inactive) added a comment -

          Approved by KTI for inclusion on 2.1.3.

          Show
          Jessica Coltrin (Inactive) added a comment - Approved by KTI for inclusion on 2.1.3.
          Hide
          Corey Pedersen (Inactive) added a comment -

          When dealing with CXF 2.7.0 care should be given to version of jaxb-impl. Version of jaxb-impl version 2.2.6 should be used as possible.

             There appears to be a problem with the 2.2.5 version of jaxb-impl which cxf 2.7.0 depends on by default.
             Get the following exception when attempting to run cxf-java2ws-plugin on services that use certain Enums:
          
          java.lang.ClassCastException: com.sun.xml.bind.v2.model.impl.RuntimeEnumLeafInfoImpl cannot be cast to com.sun.xml.bind.v2.model.impl.ClassInfoImpl
          
          
          Show
          Corey Pedersen (Inactive) added a comment - When dealing with CXF 2.7.0 care should be given to version of jaxb-impl. Version of jaxb-impl version 2.2.6 should be used as possible. There appears to be a problem with the 2.2.5 version of jaxb-impl which cxf 2.7.0 depends on by default . Get the following exception when attempting to run cxf-java2ws-plugin on services that use certain Enums: java.lang.ClassCastException: com.sun.xml.bind.v2.model.impl.RuntimeEnumLeafInfoImpl cannot be cast to com.sun.xml.bind.v2.model.impl.ClassInfoImpl
          Hide
          Peter Giles (Inactive) added a comment -

          No objections from the KTI. Travis already committed this upgrade, so... resolving.

          Show
          Peter Giles (Inactive) added a comment - No objections from the KTI. Travis already committed this upgrade, so... resolving.

            People

            • Assignee:
              Peter Giles (Inactive)
              Reporter:
              Travis Schneeberger
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Structure Helper Panel