Uploaded image for project: 'Kuali Rice Development'
  1. Kuali Rice Development
  2. KULRICE-8951

Property editors not getting picked up on add line and collection line items

    Details

    • Type: Bug Fix
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 2.5
    • Security Level: Public (Public: Anyone can view)
    • Labels:
      None
    • Rice Module:
      KRAD
    • Sprint:
      Core 2.5.0-m6 Sprint 1
    • KAI Review Status:
      Not Required
    • KTI Review Status:
      Not Required
    • Include in Release Notes?:
      Yes
    • Story Points:
      13

      Description

      Custom property editors added to an attribute definition or input field is not getting picked up on add line or collection line fields.

        Attachments

          Issue Links

            Activity

            Hide
            acampbell Adam Campbell (Inactive) added a comment -

            confirmed still an issue 9/18/13

            Show
            acampbell Adam Campbell (Inactive) added a comment - confirmed still an issue 9/18/13
            Hide
            mztaylor Martin Taylor (Inactive) added a comment - - edited

            Looking for test case to confirm. If none found will see about putting together one from LabsCollectionAddLineNonUpdatableRefreshes.xml and UITestPropertyEditor and add to labs.

            Show
            mztaylor Martin Taylor (Inactive) added a comment - - edited Looking for test case to confirm. If none found will see about putting together one from LabsCollectionAddLineNonUpdatableRefreshes.xml and UITestPropertyEditor and add to labs.
            Hide
            mztaylor Martin Taylor (Inactive) added a comment -

            Added test case to ticket/Labs with custom property editor added to input field in a view but not seeing any issues after adding (http://env14.rice.kuali.org/kr-krad/travelAccountCollection?viewId=Lab-CollectionAddLineWithPropertyEditor). Removed propertyEditor in field and modified the TravelAccount name's atttribute definition (patch attached) but still saw PropertyEditor changes.

            Let me know if any other cases need to be tested.

            Show
            mztaylor Martin Taylor (Inactive) added a comment - Added test case to ticket/Labs with custom property editor added to input field in a view but not seeing any issues after adding ( http://env14.rice.kuali.org/kr-krad/travelAccountCollection?viewId=Lab-CollectionAddLineWithPropertyEditor ). Removed propertyEditor in field and modified the TravelAccount name's atttribute definition (patch attached) but still saw PropertyEditor changes. Let me know if any other cases need to be tested.
            Hide
            mztaylor Martin Taylor (Inactive) added a comment -

            patch to test changes applied via attribute definition

            Show
            mztaylor Martin Taylor (Inactive) added a comment - patch to test changes applied via attribute definition
            Hide
            mztaylor Martin Taylor (Inactive) added a comment -

            Code appears to be working

            Show
            mztaylor Martin Taylor (Inactive) added a comment - Code appears to be working

              People

              • Assignee:
                mztaylor Martin Taylor (Inactive)
                Reporter:
                jkneal Jerry Neal (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 3 hours
                  3h