[KULRICE-7087] platform specific performance problem w/ cached services Created: 05/Apr/12  Updated: 21/May/15  Resolved: 02/Jul/12

Status: Closed
Project: Kuali Rice Development
Component/s: Development, Performance
Affects Version/s: 2.1.0-m2
Fix Version/s: Not version specific
Security Level: Public (Public: Anyone can view)

Type: Improvement Priority: Major
Reporter: Peter Giles (Inactive) Assignee: Peter Giles (Inactive)
Resolution: Cannot Reproduce Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Similar issues:
KULRICE-8327Implement caching for Message Service
KULRICE-5319Implement caching on remote soap services
KULRICE-8273Add caching to style service to improve EDocLite performance
KULRICE-8714Bug related to caching used to improve role service performance.
KULRICE-5127Fix infinite recursion problem w/ GlobalResourceLoaderServiceFactoryBean
KULRICE-5638Figure out how to make caching possible for services in the core module
KULRICE-10091Performance problem with validation script on ajax details
KULRICE-7139Role service does not seem to have caching any more
KULRICE-4391Expose the IdentityManagementService as a web and java service on the service bus
KULRICE-2315Implement caching of data to the IdentityManagementService implementation
KAI Review Status: Not Required
KTI Review Status: Not Required

 Description   

I encountered nearly a 10x slowdown in the data creation portion of RepositoryCreateAndExecuteIntegrationTest after caching was added to KRMS services. I've tried running it on a couple of different Ubuntu Linux boxes (one 32 bit and one 64 bit) and saw the performance issue on both. On the other hand, a couple of colleagues have run the test on their systems (both Macs) and had it load the data quite quickly. It would be good to get to the bottom of what is going on here.



 Comments   
Comment by Jessica Coltrin (Inactive) [ 28/Jun/12 ]

peter, is this still an issue?

Comment by Peter Giles (Inactive) [ 28/Jun/12 ]

Last time I checked it was. I haven't had a chance to go back and look at it more closely, but when I run that integration test it is darned slow on my workstation for some reason.

Comment by Jessica Coltrin (Inactive) [ 28/Jun/12 ]

Erik - I'm assigning this to see if you can reproduce on one of our server environments.

Comment by Peter Giles (Inactive) [ 02/Jul/12 ]

Actually, good new here. I just ran the test where the "agenda creation" portion was taking ~1 minute, and it took less than 2 seconds. Resolving

Generated at Thu Apr 02 14:57:15 CDT 2020 using JIRA 6.1.5#6160-sha1:a61a0fc278117a0da0ec9b89167b8f29b6afdab2.