[KULRICE-7332] Tooltip behavior is inconsistent Created: 19/May/12  Updated: 16/Jan/15

Status: Open
Project: Kuali Rice Development
Component/s: Development, User Experience (UX)
Affects Version/s: None
Fix Version/s: Backlog
Security Level: Public (Public: Anyone can view)

Type: Bug Fix Priority: Major
Reporter: Jerry Neal (Inactive) Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: Old
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Cloners
cloned from KULRICE-7208 Template Closed
Similar issues:
KULRICE-7870Tooltips are not removed if a timed refresh occurs while they are open
KULRICE-13957Tooltips on input fields with left label cause the input to slip under the label
KULRICE-11700Replace tooltip implementation with Bootstrap
KULRICE-11634Change tooltips to use bootstrap tooltips
KULRICE-7312Client-side validation tooltip doesn't open (for timed interval) when other validation treatment is applied
KULRICE-10021Remove default initialization of tooltip
KULRICE-8194Implement disabledReason with tooltip
KULRICE-8940Tooltip Edit
KULRICE-7286Tooltip swapping for controls (set tooltip content and validation message content)
KULRICE-13259Widgets tooltip help not displayed correctly
Rice Module:
KRAD
KAI Review Status: Not Required
KTI Review Status: Not Required

 Description   

I tried out a 2.2.0-M1 tooltip in an enabled & disabled Uif-InputField with this statement:

<property name="toolTip">
<bean parent="Uif-Tooltip" p:tooltipContent="It's Tool Time!"/> </property>

and sometimes the tooltip appears on mouse hover, and sometimes it doesn't. And sometimes it stays there even after the mouse has left the field. At one point I had both fields displaying the tooltip even tho the mouse was nowhere near either field. On Win7 I tried IE8 and the latest Safari & Firefox and got mixed results, but none of them worked as desired.



 Comments   
Comment by Samuel Holtzkampf (Inactive) [ 21/May/12 ]

Can replicate behaviour when adding tooltip directly on fields. Would recommend not to add tooltips on the whole field but rather on the control or label - this seems to resolve any inconsistent behaviour. When added on the field the tooltip will get triggered on empty spans. Will investigate how to avoid this issue.

Comment by Jessica Coltrin (Inactive) [ 16/Oct/12 ]

moving non-blocker and non-critical m4 Jiras to 2.2-backlog

Comment by Samuel Holtzkampf (Inactive) [ 10/Apr/13 ]

A plugin that we might want to look at to replace current tooltip : http://calebjacob.com/tooltipster/. The unminified source is available and looks like all the options we need is included.

Generated at Wed Apr 08 05:43:04 CDT 2020 using JIRA 6.1.5#6160-sha1:a61a0fc278117a0da0ec9b89167b8f29b6afdab2.