[KULRICE-7783] Finish cleanup of Ajax code Created: 02/Aug/12  Updated: 03/Apr/13  Resolved: 19/Aug/12

Status: Closed
Project: Kuali Rice Development
Component/s: Development
Affects Version/s: None
Fix Version/s: 2.2.0-m4, 2.2
Security Level: Public (Public: Anyone can view)

Type: Task Priority: Major
Reporter: Jerry Neal (Inactive) Assignee: Jerry Neal (Inactive)
Resolution: Complete Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
cloned from KULRICE-7208 Template Closed
Similar issues:
KULRICE-1811Code cleanup
KULRICE-6608Misc. KRMS Code cleanup
KULRICE-6840UIF Framework - Framework Improvements (Template Cleanup)
KULRICE-7474CLONE - UIF Framework - Framework Improvements (Template Cleanup)
KULRICE-7581Cleanup from Master/Detail Code Review
KULRICE-10052Cleanup parseExpression method
KULRICE-11659Additive Database Structure: Testing and code cleanup
KULRICE-8775xapool cleanup errors
KULRICE-13250Ajax Retrieval Library Example: IndexOutOfBoundsException
KULRICE-7179Cleanup issues from Tooltip code review
Rice Module:
KAI Review Status: Not Required
KTI Review Status: Not Required


Remaining cleanup items:

  • Need AjaxReturnType on Action component and pass through on actionHandler
  • Remove renderFullView, not needed since we can look at the returnType
  • Rename handleIncidentReport to checkForIncidentReport and cleanup code
  • Remove old ajax code not needed anymore (like updatePageCallback)
  • retrieveComponent has duplicate code with updateComponentHandler
  • Make sure optional parameters are at end of ajax methods and documented as optional on the param tag
  • Redo navigation action links so they don't call handleActionLink but use the standard ajax submit (passing navigateToPageId as submitdata)
  • add constants in krad.variables.js for return types (like "update-page")

In UifDocumentDefinitions.xml, see if we can change:

<bean parent="Uif-PrimaryActionButton-Small" p:methodToCall="downloadAttachment"
p:actionLabel="download attachment" p:title="download attachment"
p:onClickScript="writeHiddenToForm("skipViewInit", "true");writeHiddenToForm("renderFullView", "false");writeHiddenToForm("unblockUIOnLoading", "true");writeHiddenToForm("actionParameters[selectedLineIndex]", "@



to use dataAttributes for the hiddens (besides the one actionParameters which can write the property directly)

p:dataAttributes="skipViewInit:true, ..."

Comment by Jerry Neal (Inactive) [ 07/Aug/12 ]

Might want to add to Action completeCallback as well for code that should run both on success and error

Comment by Jeff Domeyer (Inactive) [ 04/Dec/12 ]

Show/hide inactive records doesn't work.
UifControllerBase -> toggleInactiveRecordDisplay(...)
line 295
String collectionGroupId = request.getParameter(UifParameters.REQUESTED_COMPONENT_ID);
That parameter is no longer passed, causes a stack trace later.

Changed it to:
String collectionGroupId = uifForm.getPostedView().getViewIndex().getCollectionGroupByPath(uifForm.getActionParamaterValue(UifParameters.SELLECTED_COLLECTION_PATH)).getId();

That at least get's the data back, but the toggling beans in UifFieldDefinitions

They both have the same additionalSubmitData, seems like the hide one should have the inverse of what the show one has.

Even with changing that, seems like it's still busted.

It looked like this was the jira (revision 34099 in svn) that introduced this regression.

Comment by Jerry Neal (Inactive) [ 04/Dec/12 ]


Would you mind to create a new Jira for this?


Generated at Wed Jul 08 03:13:29 CDT 2020 using JIRA 6.1.5#6160-sha1:a61a0fc278117a0da0ec9b89167b8f29b6afdab2.